How To

Install Intel HD Graphics 3000, 4400, 4600 on macOS with Full QE/CI

Written by John

In this guide, you will learn how to Install Intel HD Graphics 3000, 4400 or 4600 Kext on OS X El Capitan, macOS Sierra and High Sierra. It works on all Intel HD 3000, 4400, 4600 sometime working with Intel 4200. If your Graphics does not belong to one of the Graphics, this guide is not for you, unfortunately.

In case if you do not have macOS installed on your computer, you can find out more details about installing OS X on my website.

Before you proceed, it is critical to understand that the performance of your computer after Install Intel HD Graphics 3000/4400/4600 Kext  may vary. If you have successfully enabled native resolution on your display, it is now time to enable partial acceleration. In macOS, full acceleration requires that both Quartz Extreme and Core Image (QE/CI) work together.

Quartz Extreme and Core Image (QE/CI) should work in conjunction to enable full acceleration on macOS. You have to boost the graphic power to maximum. In case if you haven’t boosted your graphic card, it may lead to mouse tearing, graphic related issues and poor refresh rate. Therefore it is crucial to ensure that your graphic card is fully accelerated.

All tool: https://goo.gl/oQCZX4

Steps to Install Intel HD Graphics 3000, 4400, 4600 on macOS

Step 1: Install all Kext with Kext Utility

After you extract Intel Graphics Kext.zip. Install Kext utility. Open then Drag all kext to Kext utility:

Install Kext with Kext Utility

Install Kext with Kext Utility

Select Target Disk is El Capitan then click Install

Select Target Disk

Select Target Disk

Step 2: Mount EFI Partition with Clover Configurator

Extract Clover Configurator.zip, open Clover, select Mount EFI then click Mount EFI Partition

Mount EFI Partition

Mount EFI Partition

Step 3: Copy Config.plist to EFI Partition

Open EFI Partition, open EFI\Clover, copy and paste this file Config.plist

Copy and Paste Config File

Copy and Paste Config File

Select Replace file

Replace File

Replace File

Step 4: Copy all Kext to EFI Partition

Open EFI Partition, open EFI\Clover\Kexts\Other, copy all Kext file then paste here

Copy all Kext to Clover

Copy all Kext to Clover

Done! Now, Reboot your OS X El Capitan.

Featured Posts

71
Leave a Reply

avatar
31 Comment threads
40 Thread replies
10 Followers
 
Most reacted comment
Hottest comment thread
35 Comment authors
João Pedro RamosJohnVitaliyemirFreeMan (@FreeSlam) Recent comment authors
newest oldest most voted
João Pedro Ramos
Guest
João Pedro Ramos

Hello! Firstly, I would like to thank you for the explanation you have made, Thank you!

But I had some problems, the first is the same as the 1536MB ID system of my Intel Graphics 4400 it starts to give several errors in Google Chorme and Whatsapp.
These bugs are like image flaws.

And the other problem, that was using a VDA.

How can I solve both problems?

** Sorry, I’m Brazilian and I don’t speak very well

Vitaliy
Guest
Vitaliy

Hello! I can’t find Config.plist in the archive. Could you help please?

emir
Guest
emir

hello i have a problem after opening the refi driver. there isn’t anything in there other than a file named ‘apple’ can you help

FreeMan (@FreeSlam)
Guest

I have a question this tutorial is working with a intel hd 4000 desktop and z77 chipsed with intel core i7 3770k ? thanks

Kiran
Guest
Kiran

Bro i am Really really Thankful to you………I saw several posts but it didnt work….But You saved me…Thanks So much….

LT
Guest
LT

I have a odd issue with this graphics card. I went thru the steps mentioned and it works only if the kext are loaded into S\L\E also only if I happen to boot with -x if I boot without it panics and will repeat the last panic error. And then to get it to boot as normal without -x being added I have to uncheck the inject Intel to get to boot normal but then it brings the graphics back to 5MB. Do you have any idea as to what is causes said issue.

maykbrito
Guest

I was tired and almost giving up.. But your post saved me! TKS!

Lonnie
Guest
Lonnie

I have an N5050 laptop with an HD3000 .. I dropped the config files in the EFI/Clover folder and I see them in clover, I’ve tried them all with no success

I get stuck at IOConsolUsers:gIoScreenLockState 3, hs0, bs 0, now 0, sm 0x0

I’m running Sierra ( latest version as of 10/10/2017

The only way I can boot up is my using a fake id of 0x12345678 and it’s in low resolution.

Fabrizio
Guest
Fabrizio

It doesn’t work on my Laptop Lenovo z40-70